PubMed Won’t Support IE7

According to the NCBI Website, the NCBI resources will no longer support IE7 after January 1, 2013.  So medical librarians in Internet Explorer institutions, now is the time to start talking to your IT departments to get IE 8 or greater, or Firefox 4 or greater installed on your computers.

This means that after January 1, 2013 if you are searching PubMed using IE7 and something goes wonky, it is your problem.  They will no longer design PubMed so that it will work using IE7.

For information on other browsers like Chrome, Safari, and Opera check out the NCBI browser check list.

On a medical librarian related note, MLA’s site gets fussy using IE 7 and 8.  Bascially Internet Explorer is a frustrating browser to design for because there is designing for the rest of the web then there is designing for IE.  I am told IE 9 is better, but it is probably worth trying to get Firefox or Chrome added to your computer if you can.  However, it all depends on your IT department and their policies.  So pick your battle to at least make sure whatever browser you are allowed to use is compatible for the NCBI resources.

**Update 8/21/12  10:48am)**

ACGME won’t work with IE7 after September 1, 2012.  For more information on other browsers and versions go to:

http://www.acgme.org/residentdatacollection/documentation/browser_requirements.asp

Share on Facebook